Tool & software cần thiết: winscp & putty for windows.
1- Dùng putty log vô router, chạy lệnh sau để cài đặt igmpproxy & udpxy. Ở bước này cần cắm router qua cái modem/router nào đó để nó có thể ra được internet.
Mã:
opkg update && opkg install igmpproxy udpxy
2- Dùng winscp log vô router, tìm tới /etc/config, edit file network, sửa file network cho giống vầy:
Mã:
config interface 'lan'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option delegate '0'
option _orig_ifname 'eth0 radio0.network1'
option _orig_bridge 'true'
option ifname 'eth0.1'
option igmp_snooping '1'
option stp '1'
config interface 'wan'
option _orig_ifname 'eth1'
option _orig_bridge 'false'
option proto 'pppoe'
option delegate '0'
option ifname 'eth1.xxxx' ; xxxx thay vào số vlanid dành cho internet mà nhà mạng cấp cho bạn, vd như 2600.
option username 'username'
option password 'password'
option peerdns '0'
option dns '8.8.8.8 8.8.4.4'
option mtu '1492'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 2 3 4'
config switch_vlan
option device 'switch0'
option vlan '2'
option vid '2'
option ports '0t 1'
config interface 'iptv'
option type 'bridge'
option proto 'dhcp'
option ifname 'eth0.2 eth1.yyyy' ; yyyy thay vào số vlanid của iptv nhà mạng cấp cho bạn, vd như 1100.
option delegate '0'
option defaultroute '0'
option peerdns '0'
Tiếp, sửa file /etc/config/firewall, thêm mấy dòng sau vô firewall, ko đc xóa hay thêm sửa cái gì khác.
Mã:
config zone
option name 'iptv'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'iptv'
config rule
option src 'iptv'
option proto 'igmp'
option target 'ACCEPT'
config rule
option src 'iptv'
option proto 'udp'
option dest 'lan'
option dest_ip '224.0.0.0/4'
option target 'ACCEPT'
config rule
option src 'iptv'
option proto 'udp'
option dest_ip '224.0.0.0/4'
option target 'ACCEPT'
Edit tiếp file /etc/config/igmpproxy
Mã:
config igmpproxy
option quickleave 1
config phyint
option network iptv
option direction upstream
list altnet 0.0.0.0/0
config phyint
option network lan
option direction downstream
list altnet 192.168.1.0/24
Tiếp tới /etc/config/udpxy
Mã:
config udpxy
option respawn '1'
option verbose '0'
option status '1'
option port '4022'
option disabled '0'
option bind 'br-lan'
option source 'br-iptv'
option buffer_size '4096'
Reboot router. Done.