Ðề: Cấu hình iptv, internet VNPT trên router chạy fw openwrt
Giữ được AON là tốt, nếu GPON có thể dùng cách này:
http://www.hdvietnam.com/diendan/showthread.php?t=877924
LAN 4 của GPON sang WAN Openwrt để cấp IPTV, còn Internet dùng Client.
Em xin các bác giúp em để cho em nó hoạt động giúp em:
Cấu hình như sau:
- nhà mạng cấp IPTV và internet qua modem WR740 chia VLAN qua cổng 3, 4 là IPTV các cổng còn lại là internet. Tất cả nhà mạng là em giữa nguyên(em biết có giải pháp như bác hahoatien)
- em nối dây IPTV vào cổng lan 4 trên router WZHPG300NH (đã thiết lập VLAN), dây internet vào cổng WAN của nó.
trên file firewall em cho một số dòng của bác tienthanh và bác hamdui nhưng em không biết có sai không.
Vấn đề là khi em khởi động Router 300NH lên(modem em tắt DHCP) thì máy tính em nhận địa chỉ IP của IPTV nên không vào được mạng, em phải rút dây iptv và chỉ cắm mỗi dây internet vào và đợi khi router khởi động xong thì dây IPTV thì mọi thứ làm việc tốt. Để khắc phục nó em thêm dòng sau vào file firewall
" config forwarding
option src 'iptv'
option dest 'lan' ''
thì khi tắt 300NH đi và khởi động 300NH thì em có thể để nguyên 2 dây trên 300NH nhưng phải cắm lại dây vào máy tính(pc nhận IP của iptv) thì lúc này PC nhận được mạng và IPTV.
sau đây là các file của em
network:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd3a:d093:0238::/48'
config interface 'lan'
option force_link '1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.0.1'
option delegate '0'
option stp '1'
option _orig_ifname 'eth0.1'
option _orig_bridge 'true'
option ifname 'eth0.1'
option igmp_snooping '1'
option metric '1'
config interface 'wan'
option _orig_ifname 'eth1'
option _orig_bridge 'false'
option proto 'static'
option ipaddr '192.168.1.254'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option broadcast '192.168.1.255'
option dns '192.168.1.1'
option ifname 'eth1'
option delegate '0'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
option enable_vlan4k '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 5t'
config switch_vlan
option device 'switch0'
option vlan '2402'
option ports '0 5t'
config interface 'iptv'
option type 'bridge'
option proto 'dhcp'
option ifname 'eth0.2402 eth1.2402'
option delegate '0'
option defaultroute '0'
option peerdns '0'
option metric '10'
file DHCP
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option localservice '1'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'
option ra_management '1'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
file firewall
config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1
config forwarding
option src lan
option dest wan
config zone
option name 'iptv'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'iptv'
#config rule
# option src 'iptv'
# option proto 'igmp'
# option target 'ACCEPT'
config rule
option src 'iptv'
option proto 'udp'
option dest 'lan'
option dest_ip '224.0.0.0/4'
option target 'ACCEPT'
config forwarding
option src 'iptv'
option dest 'lan'
#config rule
# option src 'iptv'
# option proto 'udp'
# option dest_ip '224.0.0.0/4'
# option target 'ACCEPT'
config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1
# We need to accept udp packets on port 68,
# see
https://dev.openwrt.org/ticket/4108
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4
# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT
# Allow DHCPv6 replies
# see
https://dev.openwrt.org/ticket/10381
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option src_ip fe80::/10
option src_port 547
option dest_ip fe80::/10
option dest_port 546
option family ipv6
option target ACCEPT
# Allow essential incoming IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT
# Allow essential forwarded IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT
# include a file with users custom iptables rules
config include
option path /etc/firewall.user
config rule
option src 'wan'
option proto 'igmp'
option target 'ACCEPT'
config rule
option src 'wan'
option proto 'udp'
option dest_ip '224.0.0.0/4'
option target 'ACCEPT'
config rule
option target 'ACCEPT'
option _name 'multicast'
option src 'wan'
option proto 'all'
option dest_ip '224.0.0.0/4'
file QOS
config interface 'wan'
option classgroup 'Default'
option enabled '1'
option overhead '1'
option download '12000'
option upload '12000'
config classify
option target 'Priority'
option ports '22,53'
option comment 'ssh, dns'
config classify
option target 'Normal'
option proto 'tcp'
option ports '20,21,25,80,110,443,993,995'
option comment 'ftp, smtp, http(s), imap'
config classify
option target 'Express'
option ports '5190'
option comment 'AOL, iChat, ICQ'
config default
option target 'Express'
option proto 'udp'
option pktsize '-500'
config reclassify
option target 'Priority'
option proto 'icmp'
config default
option target 'Bulk'
option portrange '1024-65535'
config classgroup 'Default'
option classes 'Priority Express Normal Bulk'
option default 'Normal'
config class 'Priority'
option packetsize '400'
option avgrate '10'
option priority '20'
config class 'Priority_down'
option packetsize '1000'
option avgrate '10'
config class 'Express'
option packetsize '1000'
option avgrate '50'
option priority '10'
config class 'Normal'
option packetsize '1500'
option packetdelay '100'
option avgrate '10'
option priority '5'
config class 'Normal_down'
option avgrate '20'
config class 'Bulk'
option avgrate '1'
option packetdelay '200'
trên đây là cấu hình con WZRHPG300NH mong các bác chỉnh sửa giúp em thình trạng trên. em xin cảm ơn